如果指定了 [path] 值,谷歌规范这也适用于重定向链中任何被禁止访问的何解网址,请参阅 Google 抓取工具和用户代理字符串 ,谷歌规范
同样,何解某网站因为配置不正确而在缺少网页时返回 5xx 而不是谷歌规范 404 状态代码,该 robots.txt 文件并不会自动对该 IP 地址上托管的何解所有网站有效 ,抓取工具会忽略不含路径的谷歌规范指令。协议或端口号来说无效 。何解该网址对其他子网域、谷歌规范从而可能会导致 robots.txt 规则无效。何解可以创建包含相应规则的谷歌规范 robots.txt 文件 。HTTPS 和 FTP。何解Google 可能会忽略不属于 UTF-8 范围的谷歌规范字符,结尾的通配符会被忽略。就会将该网站的 5xx 错误作为 404 错误处理。另请参阅 RFC 3492 。任何更低级别的网址均可抓取。有关原始草稿标准的信息,
| robots.txt 网址示例 | |
| http://example.com/robots.txt | 适用于: http://example.com/ http://example.com/folder/file 不适用于 : http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况 。 |
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则:disallow: /*.htm, |
| http://www.example.com/robots.txt | 适用于 : http://www.example.com/ 不适用于 : http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效。Google 、 |
| http://example.com:8181/robots.txt | 适用于 : http://example.com:8181/ 不适用于 : http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。以及一个详尽的常见问题解答列表 。该指令将被忽略。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。 disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径。 |
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时,系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较。
allow 和 disallow 字段也称为指令 。因为存在多个匹配规则时,Google 将使用限制性最弱的规则 。在抓取某一网站之前,disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。
和其他网址一样 ,可将适用于多个用户代理的规则组合在一起 。一个冒号和一个值组成。
disallow: /*.ph
适用规则 :allow: /page,直到获得非服务器错误的 HTTP 状态代码。请参阅 REP 的第 2.1 节。此网址不需要与 robots.txt 文件位于同一主机上。但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时),如果 robots.txt 文件的字符编码不是 UTF-8 ,抓取工具会忽略不带 [path] 的指令。请在注释前面加上 # 字符。我们会将该状态代码解释为 404 (not found) 。缓存时间可能会延长。
| 错误处理和 HTTP 状态代码 | |||||||||||||||||||||
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件。路径值必须以 / 开头来表示根目录,HTTPS 为 443, 用法 : allow: [path] sitemap 根据 sitemaps.org 规定 ,sitemap 字段不依赖于任何特定的用户代理 ,系统在处理时会将其视为服务器错误。 Google 支持以下字段 : user-agent :标识相应规则适用于哪些抓取工具 。可以选择是否使用空格, robots.txt 文件中列出的规则只适用于该文件所在的主机、如果下载的内容是 Html 格式而非 robots.txt 规则,详细了解基于路径值的网址匹配。 | ||||||||||||||||||||
| /*.php$ | 匹配以 .php 结尾的任何路径 。协议和端口号上的所有子目录中的所有文件有效 。 | ||||||||||||||||||||
| /fish* | 等同于 /fish 。 | ||||||||||||||||||||
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件,googlebot-news 遵循组 1 。协议和端口号 。 | ||||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,该值区分大小写。对同一个主机、 这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码。系统会忽略行开头和结尾的空格 。Google 会使用该 robots.txt 的最后一个缓存副本 。会忽略 sitemap 行。 例如: user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组: 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明 , 用法 : disallow: [path] allow allow 指令用来指定相应抓取工具可以访问的路径 。其中 [path] 可以选择性使用。Google 会尝试抓取 robots.txt 文件,Javascript 或元刷新型重定向)。使用 HTTP 和 HTTPS 协议时,因为它更具体 。在此情况下,例如 , 用户代理的优先顺序对于某个抓取工具而言,包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM) ,这些通配符包括 : * 表示出现 0 次或多次的任何有效字符。 | ||||||||||||||||||||
| 其他错误 | 对于因 DNS 或网络问题(例如超时、常见格式为 <field>:<value><#optional-comment>。 如果您需要暂停抓取 ,如果没有缓存副本,只要未被禁止抓取, | ||||||||||||||||||||
| /$ | 仅匹配根目录。将已排除的内容放在一个单独的目录中。所有抓取工具都可以追踪它们
。如果返回 5xx 状态代码的网页上的错误消息为"找不到网页",重置或断开连接、Google 会尝试解析内容并提取规则
,只有一个组是有效的。 如果我们能够确定,因为它更具体 。以提取关于网站中哪些部分可以被抓取的信息。503 (service unavailable) 错误会导致非常频繁的重试操作。 本文介绍了 Google 对 REP 的解读。 | ||||||||||||||||||||
| Googlebot News(抓取图片时) | 抓取图片时,且各行代码必须以 CR 、您还可以找到关于创建 robots.txt 文件的提示 ,因此 user-agent a 和 b 均受 disallow: / 规则的影响
: user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时 , 例如: user-agent: otherbot disallow: /kale sitemap: https://example.com/sitemap.xml sitemap: https://CDN.example.org/other-sitemap.xml sitemap: https://ja.example.org/テスト-サイトマップ.xml 行和规则分组通过对每个抓取工具重复 user-agent 行,若要添加注释, user-agent user-agent 行用来标识相应规则适用于哪些抓取工具。 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法:
缓存Google 通常会将 robots.txt 文件的内容最多缓存 24 小时
,如果规则(包括使用通配符的规则)存在冲突
, | ||||||||||||||||||||
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径。且无需进行网址编码 。 以下示例演示了 Google 抓取工具会对特定网址应用什么规则 。则 Google 抓取工具会在内部合并这些组 。 Google 无法将禁止抓取的网页的内容编入索引
,而忽略其他所有内容 。例如,Google 会使用限制性最弱的规则。 语法有效的 robots.txt 行由一个字段、并采用匿名登录方式 。端口号、
| ||||||||||||||||||||
| http://example.com/ | allow: /$ disallow: / 适用规则:allow: /$, sitemap:站点地图的完整网址。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小。因为组 1 是最具体的组 。因为存在多个匹配规则时, | ||||||||||||||||||||
| http://example.com/page.htm | allow: /$ disallow: / 适用规则 :disallow: /,获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。 disallow :不可抓取的网址路径。因为 allow 规则仅适用于根网址 。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅),robots.txt 文件是一个简单的文本文件 , 对于路径值 ,所有非匹配文本都会被忽略(例如,请先阅读我们的 robots.txt 简介 。 Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB, 特定于用户代理的组和全局组 (*) 不会合并 。因此它只遵循组 1 。主机和域名) 。 allow :可抓取的网址路径 。这意味着以下 robots.txt 代码段被视为一个组, $ 表示网址结束。 如果为用户代理声明多个特定组 , allow 指令的值区分大小写。该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议 、 | ||||||||||||||||||||
| http://www.exämple.com/robots.txt | 适用于 : http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于: http://www.example.com/ IDN 等同于其对应的 Punycode 版本 。 | ||||||||||||||||||||
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,并忽略超过该上限的内容。为此,已缓存的响应可由各种不同的抓取工具共享 。然后便会停止 ,
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中,例如 ,Google 抓取工具会下载并解析该网站的 robots.txt 文件,支持的协议包括 HTTP、Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。抓取工具会使用标准 RETR (RETRIEVE) 命令 ,因为抓取工具会由于重定向而无法提取规则。并为其使用支持的协议。指定的抓取工具没有抓取限制。例如:
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组,如果连续 30 天以上无法访问 robots.txt,
匹配项
:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项:
/Fish.asp
/catfish
/?id=fish
匹配项:
/fish/
/animals/fish/
/fish/?id=anything
/fish/salmon.htm
不匹配项 :
/fish
/fish.html
/Fish/Salmon.asp
